Bruce 的玩具間

my works and notes on ruby, rails, git, ubuntu linux, mac os x, etc...

Sublime Text wtih Ruby 1.9/Rails 3 syntax checking

| Comments

The Ruby 1.9 hash syntax causes syntax check errors in Sublime Text 2 with a red exclamation mark.

TL;DR

Preferences -> Package Settings -> SublimeLinter -> Settings - User

{
    "sublimelinter_executable_map":
    {
        "ruby": "rvm-auto-ruby"
    }
}

And restart Sublime Text 2

Configuring the SubLime Linter Plugin to use Ruby 1.9 Syntax

ruby rails

Comments

comments powered by Disqus